domingo, 23 de diciembre de 2007

LaTeX desde cero

Ya hablé sobre qué es LaTeX y sus ventajas. Ahora intento profundizar más. Resolveremos las dudas de la gente que quiere saber sobre entornos gráficos para LaTeX, y que le gustaría escribir las eñes y las tildes (aunque latex se maneja en su forma más simple con ASCII).

Paquetes necesarios [actualizado]
Para compilar LaTeX es necesario:
texlive-latex-base (junto con sus dependencias)
texlive-latex-extra
texlive-math-extra (específico para escritura matemática)

y en general es recomendable todos los texlive-*** salvo idiomas extranjeros, porque incluyen las librerías CTAN más usuales.

Interfaces
Yo edito los archivos de LaTeX con gedit, pero habrá quien quiera manejarse con entornos gráficos que tienen todas las opciones a mano. Para ello recomiendo TexMaker (sudo apt-get install texmaker). En orden de preferencia:

TexMaker: Muy completo. Pasa a dvi, ps y pdf.
Kile: Es para KDE principalmente (ocupará más y consumirá más recursos si no usas KDE), pero lo puedes usar en GNOME, no está mal y pasa a PDF, dvi, html... con un clic. Es como TexMaker pero para KDE.
LyX: Es visual, interpreta los comandos LaTeX instantáneamente. Mejora por versiones.

Tildes, diccionarios, eñes...
Instala latex-ucs (sudo apt-get install latex-ucs) ésto te permitirá usar eñes y tildes (o cualquier carácter UTF8).

\usepackage[spanish]{babel} % Division de sílabas y títulos en español.
\usepackage[utf8]{inputenc} % Para poner acentos y eñes directamente.
\usepackage{ucs} % Altenativamente al anterior.
\usepackage{amsmath} % La American Mathematical Society creó este paquete de "Higher Mathematics".

Por lo que parece, \usepackage[latin1]{inputenc} Se usa en Windows. En linux no permite caracteres UTF8.

Instalar archivos fuente
Averigua el archivo que te da error. Suele ser que sea un archivo fuente. Supón que sea picins.sty
  1. Búscalo en synaptic, pues puede que te falte un archivo texlive u otro.
  2. Vamos al repositorio de paquetes de LaTeX: http://www.ctan.org
  3. O directamente lo buscamos por nombre: http://www.ctan.org/search.html#byName
  4. Lo descargamos (y descomprimimos si es necesario).
  5. Lo copiamos como root en: /usr/share/texmf/tex/latex
sudo cp <ruta>/picins.sty /usr/share/texmf/tex/latex

Compilar
Si tienes un archivo *.tex o lo has creado con un editor cualquiera y quieres compilarlo, entra en la carpeta desde consola y pon:
latex archivo.tex Si quieres pasarlo a *.dvi
pdflatex archivo.tex Si quieres pasarlo a *.pdf

Los programas mencionados antes lo hacen con un botón.

Otros programas útiles para manejo de latex y otros tipos de archivos:
latex2html, latex2rtf, gnuhtml2latex, dvipdf, tth, unrtf, netpbm, dvipng, chktex, rubber, tetex-doc, pgf, preview-latex-style
lmodern, sam2p, psutils

Paquetes útiles
tipa Simbolos fonéticos (IPA)
circ-tex Circuitos y diagramas ópticos
latex-xcolor Manejo de color
latex-beamer Hacer presentaciones

10 comentarios:

Kunzahe dijo...

Hola,

soy nuevo en esto de LaTeX, uso ubuntu 7.10, y me gustaría saber por qué al instalar los paquetes tetex, me instala también texlive, si dices que no son compatibles.

Otra cosa que quiero saber es, ya que al instalar tetex-extra me instala un montón de idiomas (son paquetes texlive), y yo sólo quiero español, quiero instalar sólo el de español, pero hay otros paquetes que vienen con tetex-extra que no sé de que son, y quiero saber si es recomendable instalarlos:

preview-latex-style, texlive-bibtex-extra, texlive-font-utils, texlive-fonts-extra, texlive-generic-recommended, texlive-latex-extra, texlive-math-extra, texlive-pictures, texlive-pstricks, texlive-publishers.

Gracias de antemano.

Rutrus dijo...

Tienes toda la razón, y es que lo han debido actualizar. Dije que era incompatible porque en viendo las características de los paquetes texlive ponía "Incompatible con tetex*". Ahora se puede leer: teTeX is no longer developed upstream, and has been replaced by the TeX Live collection.

Antes se podía instalar los tres paquetes únicamente. Ahora recomiendan TeX Live, por lo que habrá que instalar únicamente texlive-latex-base junto con sus dependencias (que se seleccionarán automáticamente) más los paquetes texlive que necesites (math, fonts...). Voy a actualizar el post. Gracias por el aviso.

Nicolas dijo...

mira...mi problema con latex es q no pudo compilar por una d las rrazones que diste, y es que me falta un archivo fuente q es exactamente el d ejemplo que diste, el "picins.sty", pero me meto a la pagina que diste para descargarlo y no puedo, o sea, pincho el download y aparece una pagina en codigos, no me sale la opcion de descarga comun...como lo puedo hacer ??, o si tienes la opcion de mandarme el archivo en algun mail...

te lo agradezco de antemano...si me das alguna respuesta podemos contactarnos ;)

Rutrus dijo...

Hola nicolas, el enlace que buscas es éste: picins.sty Aparece dentro del listado de su página correspondiente, aunque también puedes descargar todos esos archivos en zip.

Tu problema debe ser que cuando pinchas en el enlace se ve el archivo en texto plano en lugar de descargarse. Para ello pincha en el enlace del archivo con el botón secundario y dale donde pone "Guardar enlace como...". Desde Firefox, otra opción es visualizar el archivo que no puedes descargar y darle a "Guardar como..." (Ctrl+S) desde el menú Archivo.

Un saludo.

Nicolas dijo...

Ok.... muchas gracias...lo logre descargar y todo, la cosa es que no se dond colocarlo porque o e tratado d colocar en casi todos los paquetes del miktex y aun asi me arroja el error de que no encuentra el archivo... a que se debe??

SAludos

Rutrus dijo...

¿No tienes la carpeta /usr/share/texmf/tex/latex ? Para copiarlo como root puedes hacer "sudo nautilus" y hacerlo gráficamente. Si no fuera esa la carpeta y solucionas el problema te agradecería que lo comentaras aquí. Un saludo.

Nicolas dijo...

si tngo esa carpeta...o sea, la ubicacion q tngo yo es asi: "D:\Nicolas\Ayudantia\Miktex\tex\latex", asi q asumo q es la misma...y ahi pegue lo dos archivos faltantes, xq cuando compilo, los archivos que busca estan en esta carpeta (nose si se entiende), y x esa razon pegue los archivo ahi, pero aun asi al compilar me arroja el error de que no encuentra en archivo faltante... :S
me estoy desesperando, tngo q entregar el trabajo antes dl lunes
xD


SAludos :)

Rutrus dijo...

Al parecer estás en windows, prueba a reiniciar, a volver a abrir el programa...

Si esa es la carpeta y ese es el archivo que te falta debería funcionar. Busca gente que tuvo el mismo problema en un buscador, a ver qué tal.

MILLER dijo...

Hola a todos
uso windows y he descargado el archivo latex2rtf-1.9.19a_win y lo he descomprimido pero no se donde debo agregar la carpeta y como hago para usarlo con latex2rtf [opciones] NombreArchivo.[tex], tengo instalado winedt, miktex, imagemagick, Ghostscript 8.00, GSview 4.3. muchas gracias

saludos
miller

Nano-Andy dijo...

hola! uso ubuntu 8.4 e instale LyX, pero no puedo colocar tildes. Es un problema, no se q hacer, pueden ayudarme?